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add-in for SOLIDWORKS 

User Guide 

 

This document is a user and setup guide with tips and tricks on how to render 

photorealistic images in real-time, apply decals and create animations. 
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OVERVIEW 
AMD Radeon™ ProRender is a free un-biased rendering add-in for your design and 

manufacturing needs in Dassault Systèmes SOLIDWORKS®. Using physically 

accurate path-tracing technology, AMD Radeon ProRender can produce stunning 

photorealistic images of your model and provides real-time interactive rendering 

and continuous effects adjustments to help create the perfect rendered image. 

AMD Radeon ProRender supports real-time updates for changes that to the parts 

and assemblies within SOLIDWORKS, offering a continuous render preview.  

This user manual will describe how to setup AMD Radeon ProRender for 

SOLIDWORKS and how to use it from adding decals through to the final save of the 

rendered image. This guide will also explain the additional features such as post 

render image adjustments, decal placement, generating rendered animation files 

from SOLIDWORKS motion studies, and how to incorporate AMD Radeon 

ProRender into your design workflow. 
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Supported Platforms 
AMD Radeon ProRender for SOLIDWORKS v1.0.3.1 runs on both GPUs and CPUS. OpenCL™ 1.2 is 

required for GPUs. 

Software 
• Dassault Systèmes SOLIDWORKS® 2016+ 

Operating System 

• Microsoft Windows® 10 (64-bit)  

• Microsoft Windows® 8.1 (64-bit)  

• Microsoft Windows® 7 (64-bit)  

Join the Discussion 

Provide feedback here for all AMD Radeon ProRender plug-ins. 

https://discord.gg/4k8p76N
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Install AMD Radeon ProRender add-in 
Download the AMD Radeon ProRender add-in for SOLIDWORKS and launch the setup, agreeing to the 

license.  

      

AMD Radeon ProRender will check your hardware and software to ensure requirements and you can then 

choose where to install the add-in. 
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Install the AMD Radeon ProRender Add-In. Then, click on Register... to get your activation key. 

      

Register using your information. You will receive your activation key after clicking Request Download. 

Enter it into the installer and continue the installation. 
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AMD Radeon ProRender Setup 
Launch SOLIDWORKS 2016 or higher. Go to Tools > Add Ins… to enable the AMD Radeon ProRender 

add-in. 

 

Verify that the AMD Radeon ProRender line has both the active and start-up checkboxes checked.  

1 
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AMD Radeon ProRender Start Up 
Go to File > Open... to import a model OR, go to File > New to start a new part or assembly. 

 

Locate the top toolbar in the main SOLIDWORKS interface. If there is no AMD Radeon ProRender tab, 

right-click any of the tabs (Features, Sketch, Evaluate…etc.) and enable the AMD Radeon ProRender  tab. 

 

The AMD Radeon ProRender tab should include the following buttons. 
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Rendering Window Overview 

 

In the Rendering Window, you can: 

• view the number of rendering iterations for the current frame 

• apply post effects 

• apply decals 

• change settings  

• change environment settings 

• view part properties 

• pause/continue/restart the render process 

• save the image 

• synchronize the render with changes you have made in SOLIDWORKS (if it does not refresh automatically) 
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By default, the rendering window will show the same view as the current window in SOLIDWORKS. Any 

changes that are made in SOLIDWORKS will be reflected in real-time in the AMD Radeon ProRender 

window. This window is where post editing effects are applied to the rendered image. 

Tip: The AMD Radeon ProRender window floats above the SOLIDWORKS window, but you can 

place the two windows side by side. 
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Properties Page Overview 

 

The Properties Page is a standard SOLIDWORKS properties page and appears in the SOLIDWORKS 

window. In the Properties Page, you can: 

• adjust the output frame resolution and size 

• select the render device(s) 

• adjust the render completion settings 

• adjust when the rendered image is saved 

• change the mesh quality and render quality 

• adjust floor reflection/shadow settings 

• enable debug options when working with AMD support 
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Camera View Setup 
By default, the view of the model in the AMD Radeon ProRender window is the same as the view in the 

currently active window in SOLIDWORKS. 

Orbit Camera Setting 

The Orbit Camera checkbox in AMD Radeon ProRender enables you to override the camera view in the 

active SOLIDWORKS window and change it independently without affecting the SOLIDWORKS view. 

Once the checkbox is checked, the camera controls in AMD Radeon ProRender are the same as the 

default ones in SOLIDWORKS.  

Note: When Orbit Camera is enabled, and the camera is moved interactively, the render 

resolution is reduced to provide greater interactivity. Once interaction stops the render 

resolution and quality return to the selected settings. 
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Image Output Settings  
These settings are set in the Properties Page and are only reflected in the Rendering Window. It will not 

affect the actual model in SOLIDWORKS. 

Tip: Remember to hit the green check mark or the settings will not update in Rendering Window! 

 

Resolution Settings 
In the Properties page, the output resolution and image size can be set. This will not change the model 

resolution in SOLIDWORKS but only in the Rendering Window. There are pre-set resolutions as well as 

standard sizes. 

Tip: Increasing the resolution can dramatically increase both the frame render time and also the 

amount of graphics card memory required. 
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Render Settings 

Choose the device for rendering (supports GPU and CPU).  

Tip: Active real-time rendering using GPU is faster than CPU.  

 

 

Render Completion Settings 

Set when the rendering is completed by number of rendering iterations or time elapsed. If there are no 

limits set for time or iterations the render will keep rendering until the user cancels the render or closes 

the render window.  
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Quality Settings 

The quality settings for rendering can be adjusted depending on the quality of the rendered image, the 

time and the complexity of the model. 

Tip: You can tune AMD Radeon ProRender to be faster or slower by using a coarser model (i.e. 

low mesh quality) for real-time rendering. For a complicated model, it is recommended to start 

using lower quality settings until it is time to do a final render. 

 

Mesh Quality 

Mesh quality determines how SOLIDWORKS breaks the surface of models into triangles. When using a 

lower setting, the meshes are more complex and require more processing power as well as memory. As 

seen below, the curved surface in SOLIDWORKS renders into a model with more flat edges. At a high 

level, the rendered image appears to a continuous surface. 

                      

Render Quality 

Render quality depends on AA Samples and May Ray Bounces. AA Samples controls how many “shots” 

that AMD Radeon ProRender takes at the scene before updating the image and Max Ray Bounces 

changes the number of times that a ray bounces off a surface to capture reflections. 

Notice the image quality of the model when using number of ray bounces of 1 (left) and of 5 (middle) and 

of 20 (right). The transparency and colour of the model is improved with more ray bounces. In the left 

most photo, the inside of the model is black, since the surrounding light is unable to reach the inner 

surfaces due to a low ray bounce setting.  
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Tip: When using glass or other translucent appearances, use a high number of Ray Bounces to 

fully capture all reflections (generally, a good number is 6 unless there are complex, translucent 

parts).  

Improved image quality comes at a cost to other factors. The right render took more time than the left 

render to produce qualitatively, the same image quality. 

   

Tip: Consider using lower settings for preliminary renders (i.e. lower mesh and render quality) 

and changing to higher quality settings when you are near completion of design to ensure 

surface quality and colour. 

Floor Settings 

The floor settings control the reflection of the model and its shadow on the floor. 
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Shadow Intensity 

Shadow intensity controls the transparency of the shadow. Left (0.1) Right (1) 

      

 

Reflection Intensity 

Reflection intensity controls the transparency of the reflection. Left (0.1) Right (1) 

      

  



IMAGE OUTPUT SETTINGS   16  

AMD Radeon ProRender add-in for SOLIDWORKS User Guide ©2018 Advanced Micro Devices, Inc. All rights reserved. 

 

 

Roughness 

Reflections and shadows appear to be diffuse. Left (0.01) Right (0) 

      

 

Tip: For more realistic shadows on rougher surfaces, increase roughness for more diffuse 

reflections. 

 

Debug 

The Debug feature should only be used with AMD support if issues are present. This includes a trace 

ability to capture the interactions for AMD Radeon ProRender. These interactions are generated within a 

set of files showing the applied effects and the cause of error or bug. 
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Post Effects Tab 
These effects are applied to the rendered image after rendering is done in the Rendering Window. These 

settings apply to the entire scene, including the model and its interactions with the light from the 

background. 

Tip: Adjusting post effects can tweak the scene without having to restart the rendering. 

  

Tone Mapping  

Tone mapping allows you to change the brightness of the scene to display more information or balance 

details. 

Simple 

This is a simple exposure tweak and contrast option. You can brighten or darken the image by controlling 

the exposure, or having brighter or darker contrast. 

 

Non-linear (Reinhard) 

Prescale controls the brightness of darker areas (shadows), post scale controls the brightness of the 

scene and burn controls the brightness of highlights and lighter areas. 
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Photolinear 

Sensitivity is often related to the ISO setting and controls the camera’s sensitivity to light, exposure is 

related to camera shutter speed which controls the time that the shutter is open to the exposed light 

and F-stop is related to the aperture that is related to how much light is exposed to the “film”. 

 

White Balance  

Check the checkbox to enable or disable.  

This will tone the temperature of the scene to  look warmer or cooler (i.e. more red or more blue). 

Color Space: Adobe RGB, DCI-P3, Rec.2020, sRGB 

 

Gamma Correction 
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Tip: If the image is too dark, the first thing to adjust is the Gamma Correction.  

 

On the left, the rendered image is very dark. Increasing the Display Gamma brightens the scene and 

details are more visible. Left (1.00) Right (1.75) 

       

Output Levels 

Output levels controls the amount of colour that is shown. 

Black and White 

 

RGB 
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Decals Tab 
Note: Changing the decal will also restart the render! Best to use low quality settings. 

 

Go to the Decals tab and press New… to start applying a new decal.  

 

Note: Decal masks enables the background of the decal to be transparent. The image mask is a 

black and white image. Items in white remain in the decal whereas the black is removed. 
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After importing the decal, you can see the name and it acts as the color file. Click on … button to select 

the file for the mask. For this purpose, the color and the mask will be the same file. 

      

You can change the name by going to the Edit… and typing a new name. Press the X to exit. 

 

Applying Decals 
Decals are applied to the body, or a face on the body. Under Objects, either toggle bodies or faces. 

Tip: After importing the decal from New…, you can directly click on the surface you wish to apply 

the decal to – even without selecting a mask. 
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Bodies 

Toggle the Bodies button, and click on the surface to apply the decal (the star). The decal’s center will be 

placed there.

 

Click on the surface you want to apply the decal. The body will be listed on the right. 
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Applying the decal as a body will project through the entire body before it hits another surface. On the 

backside of the block, the decal is apparent.  

 

To place the decal on a single face, there are two options: 

1. Apply decal using the faces toggle 

2. Change the depth of the decal (discussed later) 

Faces 

Toggle the Faces button and then click on the face to place the decal. After clicking on the face, the body 

and the face are listed on the right. 
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Note: When selecting solely a Face, the back of the block does not have the decal projecting 

through it.  
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Projection Mapping 

If you want to move the decal, toggle the Select Position button, and click to place the decal at another 

position on the blocks face. The decal is moved towards the center of the block. 

 

If the positioning still needs to be tweaked, first click on Align Camera to position yourself normal to the 

decal.  
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On an angle, the decal looked aligned but from the normal view, the decal is not in the middle. 

 

Enable the Select Position toggle, and slightly adjust the Offset X and Offset Y (The X and Y axis are 

relative to the decal). 
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Note: You can also change the angle of the decal, but the datum point will be where you first 

clicked to placed your decal – NOT at the new decal center after the Offset X and Y. 

You can move the decal only on the surface/face that you selected (i.e. Face 5). If you want to move it to 

another face, first delete the selected face by clicking  “-“, then selecting the face that you want (i.e. Face 

4). 
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Depth 

Depth applies to decals applied to surfaces on the body, not a face. Depth refers to how far the decal is 

projected throughout the entire body. Its scale is relative to the entire length of the body. 

The decal also extends past its selected surface. Notice how it seems to drag onto the other side. Any 

pixels that extend past the edge of the applied surface are projected on the side. Depth is at 100. 

 

Decreasing the depth will shorten the decal projection throughout the block. Depth is 28.7. 
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Tip: Decreasing the depth to 0 will create a very “thin” projection of the decal on the surface and 

will not wrap the decal around the sides of the object. Similar to applying the decal to a Face 

instead of the entire Body. 

 

Size 

AMD Radeon ProRender will automatically detect the units of your model, and use the same units to 

adjust the size of the decal. When scale is set to 100, the decal displayed on the model is true to size.  

Note: If you change the units in SOLIDWORKS, close and reload the Rendering Window. 

Tip: Best to set the units in SOLIDWORKS first before doing any render editing. 
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Tip: This is useful for seeing whether a sticker of a certain size would fit onto the model. 

 

Surface 

 

Opacity 

Opacity adjusts the transparency of the decal. Left (100) Right (30) 
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Reflectivity 

The decal can show reflections of the surrounding environment. Left (50) Right (100).  

Note: If reflectivity is 100 percent, the decal is essentially a mirror.  

 

    

 

Roughness 

Roughness diffuses the reflection. Left (0) Right (20) 
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Emissive 

The decal applied acts as an emissive image (i.e. and LCD screen). In the image below, the model is lit 

from inside by the decal.  

Note: This will decrease performance and it is a computationally heavy feature. 
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Multiple Decals 

To add multiple decals, click on New… and select another decal. 

Tip: Remember to select color and mask! 

 

The decal is applied to the same face with the first decal. 

 

In Edit…, there are now two decals. You can also rename your decal if you wish.  

 

Note: In the list above, the RadeonPro decal will be laid on top of the AMD decal. To change the 

ordering of the layer, press the▲▼. 
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In the list below, the AMD decal will be on top of the RadeonPro decal.  

 

To adjust a particular decal, select the decal in the drop-down list at the top and adjust the settings for 

that decal. 

 

Tip: Remember to toggle Select Position button to move the decal! 

 

The same controls are used to move the different decals (i.e. the positioning, sizing and aligning of the 

camera).  
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Multiple Bodies 

If your assembly has multiple bodies, you can apply the decal to multiple bodies and/or faces. Ensure the 

Bodies toggle is enabled, then click on the surfaces while holding CTRL key. On the right, there should be 

two bodies selected, and toggle the select position to drag the decal on the two bodies.  

Tip: Place decals across the surfaces of bodies that are parallel for best results. 

 

 

You can even do the same with selecting the faces to prevent the decal from projecting through the 

bodies. 
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The part of the decal on each body will “stick” to that surface. If the model is moved in SOLIDWORKS, it 

will remain the same in AMD Radeon ProRender. 

 

Note: You are still able to change the size, position, scale…etc. AMD Radeon ProRender will keep 

the decals on its respective surface. 

In the image below, there is an offset in the X and Y direction, as well as an increase in scale. Notice how 

the decal still sticks to the two faces. 

 



DECALS   37  

AMD Radeon ProRender add-in for SOLIDWORKS User Guide ©2018 Advanced Micro Devices, Inc. All rights reserved. 

 

 

Curved Surfaces 

The decal is placed on the outer surface of the glass. Since the decal is applied as a projection, the decal 

that is applied on the lower part of the glass is projected. The decal is applied on the entire body, not just 

a face. 

      

To fix the alignment on curved surfaces, enable the Snap To Axis checkmark.  
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If you want to prevent the decal from projecting through the glass, select the face by toggling the Face 

button and clicking the surface to apply the decal. 

 

Then decrease the depth of the decal. 
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Decrease the depth until you can no longer see the decal extend to the other side, and only on the side 

you want. 

 

Final look at the decal on the curved surface. 
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Note: When saving the file, the decal settings save within the SOLIDWORKS model! A pop-up 

box will appear even if you did not change the model in SOLIDWORKS. 
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Environment Tab 

Lighting 

Tip: Making any changes here will restart the iterations! It is best to set the lighting first. 

 

Environment Multiplier 

By using an hdr file, the background contains enough information to display ambient lighting. The 

Ambient Multiplier is adjusted to make the surrounding light brighter or dimmer. When the ambient light 

multiplier is decreased, background details are more visible, but overall scene is darker. 

 Left (4.5) Right (0.5) 

      

Emissive Multiplier 

The Emissive Multiplier applies to objects have light emitting appearances (i.e. modelling a LED lamp). 

When increasing the emissive multiplier, the ball in the middle (which has an emissive appearance applied 

to it) seems to be brighter. Left (1.0) Right (5.0) 
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Check “Override SOLIDWORKS Environment” to customize background and lighting options. 

Background 

Select from different types of background images such as a color, gradient or using the current 

environment. 

      

Environment 

Choose between Image-Based Lighting or Sun & Sky for the Environment. 
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Image Based Lighting 

Upload an IBL file for the environment. 

 

Sun and Sky 

Set the parameters for the Sun and Sky environment. 
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Settings Tab 

Completion 

Set when the rendering is completed by number of rendering iterations or time elapsed. If there are no 

limits set for time or iterations the render will keep rendering until the user cancels the render or closes 

the render window.  

           

If you set iteration/time constraint and the render has finished and you wish to go back to rendering, set 

the Completion to Unlimited and press the Continue Button. 
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Properties Tab 
Click on any part in the model. This window shows you the Name and Mesh Quality of the selected part. 

You can also set the mesh quality of each part individually. 
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Final Render 
Tip: To balance the amount of details shown, different effects must be adjusted. There are 

trade-offs to this, as changing the effects can show surface details, but make the overall scene 

look very bright or dark.   

After editing the scene, you can export the scene settings to apply to another model. Go to File > Export 

Scene Settings. When opening the Rendering Window for another model, you can import those setting 

by going to File > Import Scene Settings.  

 

Tip: Remember to set Render Setting to high quality in the Properties Page when you are 

nearing completion of the Render for optimal quality. 

Click on Save… to export the current frame. 
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AMD Radeon ProRender Game Engine Importer 
These steps explaining how to use AMD Radeon ProRender for SOLIDWORKS are needed to create the 

assets to import into the Unreal® Engine. This tool can process post render imaging effects, apply decals 

and finetune scene details visible in backgrounds and lighting. 

Step 1: Open Model in SOLIDWORKS 

With the AMD Radeon ProRender add-in installed, launch SOLIDWORKS and open your model. 

Note: AMD’s longstanding support for RealView and Order Independent Transparency (OIT) 

yield a high-quality rendering of the CAD model. 
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Step 2: Set Render Properties 

Open the AMD Radeon ProRender add-in and set the rendering properties in the Properties Page tab. 

Note that the setting for Mesh Quality will impact game engine and VR performance, and the settings for 

Render Quality (especially Max Ray Bounces) will impact rendering speed and should only be set to 

higher values when rendering highly reflective or transparent materials. Make sure that GPU rendering is 

selected. When finished, click the green check icon to save the AMD Radeon ProRender Properties. 
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Step 3: View Render in Rendering Window 

Then click the Rendering Window tab. The progressive rendering will begin immediately after the model 

is loaded into AMD Radeon ProRender, and can be limited by either time or the number of rendering 

passes (iterations.) The angle of the viewport can be modified in real time by checking the Orbit Camera 

box and holding the middle mouse button while dragging the mouse. Zoom the camera in and out with 

the mouse wheel. Any change to the camera view initiates a fresh pass of the rendering. The AMD 

Radeon ProRender rendering is physically correct and photorealistic. 
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Step 4: Apply Decals 

Decals (from standard graphics formats like PNG, JPG, TIFF, and DDS) may be applied to bodies or faces 

of CAD parts and manipulated with multiple parameters. Applying decals will instigate a new rendering 

pass using the current AMD Radeon ProRender settings. 
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Step 5: Export AMD Radeon ProRender Scene 

From the menu (upper left corner) of the AMD Radeon ProRender window, choose Export ProRender 

Scene, which places an .frs file in the disk location of your choosing. The .frs file can be imported into 

Unreal Engine for VR visualization and interactivity with the AMD Radeon ProRender Game Engine 

Importer. 
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Animation 
In SOLIDWORKS, click on the Animation Dialog. Select the motion study in SOLIDWORKS that you want 

to animate and specify the number of frames to render per second. 
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For each frame that will be rendered, specify the number of iterations or the time for rendering 

completion. 

      

Tip: Remember that every frame is rendered – every single frame will need to have complete the 

specified number of iterations/time. Which adds up in time! 

Upon starting the render, the animation dialog will show the number of frames that need to be rendered, 

the total estimated time, and the progress of the render.  

AMD Radeon ProRender will create a video of the current view of the model in SOLIDWORKS. 
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Upon completion, AMD Radeon ProRender will render the video in the folder that contains the model by 

default.  

 

Screenshot of a single frame in the rendered video. 
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