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Introduction to DAT/EM Stereo Viewer 
The DAT/EM Systems International Stereo Viewer is a product that was introduced in DAT/EM version 
7.6 and remains in higher versions. Its purpose is to perform a relative-like orientation only, which 
produces good stereo viewing and establishes model coordinates.  

Stereo Viewer allows stereo viewing and pseudo relative (model coordinates) comparisons only. It does 
not give ground coordinates. If your project requires ground coordinates, DAT/EM encourages you to try 
our Summit Evolution stereoplotter product instead. 

Stereo Viewer does not require a camera definition file. Stereo Viewer will typically be used for historical 
imagery where the control and/or camera details are unknown. 

For licensing and viewing: 

• You will need to own a DAT/EM Stereo Viewer license and obtain an installation keycode in 
order to install this application. 

• DAT/EM Stereo Viewer added to existing DAT/EM hardware locks will require a WriteLock 
program from DAT/EM Support. 

• Stereo Viewer version 7.7 works with Windows 8.1 and 10 Professional and Enterprise. 
• For help setting up your stereo hardware, please contact DAT/EM Support. The remainder of 

this document expects that your stereo hardware is working to display OpenGL stereo. 

mailto:support@datem.com
http://www.datem.com/
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Additional notes for users who are familiar with the DAT/EM Summit Evolution stereoplotter: 

• The DAT/EM Stereo Viewer project file is similar to – but not quite the same as – a Summit 
Evolution project that only has two images and relative tie point measurements. It does not 
require a camera file, so it will never be quite the same. 

• In versions built 23 January 2019 or later, the Stereo Viewer project can be opened as read-only 
by Summit Evolution. Summit can’t modify the project and can’t create a new Stereo Viewer 
project. 

Types of Stereo and Other Display Options 
There are two stereo view types: Quad buffered stereo and anaglyph. 

 
Two project types: Quad buffered stereo and anaglyph 

Choose the type of stereo based on whether you have stereo viewing hardware installed. For example, 
set Quad Buffered Stereo if you have a Schneider Digital PluraView display system or nVidia 3DVision. 
Select Anaglyph if you have only colored film glasses or wish to take a screen shot demonstrating 
stereo. 

Use the other View menu options as desired to set the appearance of the Stereo Viewer window. 
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Preparation 
Select images with 50% to 90% overlap. The images should have similar scale and rotation. 

 
Example of Stereo Viewer Image Pair (in anaglyph stereo for demonstration purposes) 

Stereo Viewer can use many different image formats. Some of the TIF-type formats may be used as they 
are without translating them to an optimized Stereo Viewer .smti format, but other formats must either 
be converted or used with generated .pyr zoom pyramid files. The DAT/EM Image Creator tool is used to 
create .smti or .pyr files. See the section below for instructions. 

 



  
 

Page 4 of 20 
 

Image Creator 
If you know you need to process the images, or even if you are unsure of your image format, use Stereo 
Viewer > Tools > Image Creator to make optimized versions of your images.  

 

Image Creator 

1. Select the images that you will use as input. A dialog containing a list of valid input image 
formats will appear. You will need at least two overlapping images to use the Stereo Viewer. 
 

2. Select an output directory if you would like the images to be in a directory other than in their 
original location. The default file extension of .smti should prevent overwriting your existing 
images. 
 

3. Press the Process button to begin processing. This will create images suitable for use in the 
Stereo Viewer. 
 

4. You will probably not need the other options available in this tool. If you are not sure, please see 
the Image Creator training on www.datem.com in Support > Training Videos. 

http://www.datem.com/
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Create a Stereo Viewer Project 
The Stereo Viewer needs a left and a right image to present stereo.  

1. Start the Stereo Viewer application.  
 

2. Use Stereo Viewer > Edit > Project to select the images you would like to view in stereo. These 
images must have an overlap region and must be of similar scale and rotation. 
 

 
Use Project Edit to browse for the left and right image 

 
3. Select File > Save or the save icon on the toolbar to name and save the project. 

 
Save to name and save the project 

Orientation for the Stereo Viewer 
There are two tiers of orientation offered: Tie Points (also known as pseudo relative) and Rectify. 
DAT/EM recommends to do Tie Points first, then try Rectify. Rectify is the preferred method as long as 
it succeeds. For those image pairs where Rectify fails, the Tie Points method must be used as-is. 

Always measure tie points first. Choose either manual or automatic measurement from the sections 
below. 

Measure Tie Points Manually  
This Tie Points method is really a “pseudo relative”. It is very similar to a real relative orientation (RO), 
but in a real RO, the camera parameters are known. For convenience, we’re going to call this pseudo 
relative either “relative orientation” or “RO” in the remainder of these instructions, but please keep in 
mind it is always a pseudo relative orientation in Stereo Viewer. 

To measure tie points manually: 



  
 

Page 6 of 20 
 

1. Select Stereo Viewer > Orientation > Tie Points. (For those who are familiar with it, this is 
similar to Summit Evolution’s Relative Orientation dialog.) 
 

 
Stereo Viewer’s [pseudo] Relative Orientation dialog 

 
2. Perform an initial image alignment by selecting either the Auto Align or the Align… button.  

If Auto Align fails, Align must be used. Initial alignment will help set the overlap for the two 
images, making it easier for the Quick Points tool to estimate a stereo area and to make 
point measurement easier. 
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If you select Align, the two images will appear in a selection window. Click on the same 
recognizable feature in both the left and right image. This is a rough alignment and does not 
need to be pixel perfect! 
 

 
Align allows you to pick a rough alignment to help get started 

 
3. Add at least six or eight point to the list. There are two choices for this: 

• Press the  button at least six or eight times to insert blank tie points into 
the list. Six are required for this process alone. Eight are required if you want to 
proceed to the Rectify step, which is recommended. More than eight points are 
optional. 
 

• (Recommended) Select the Quick Points button Then select a number of points to 
add and a percentage from the edge value. Von Gruber points are added at even, 
calculated intervals along the right and left edges of the stereo area 
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Select the number of Von Gruber positions and press the Von Grubers “n” button 

 
Note: If you do not see a yellow rectangle around the estimated stereo area, it could be that 
Auto Align failed in the previous step. In this case, the Von Gruber points will be added to 
the left image area rather than the overlap area, and some of the points may be outside the 
stereo area. In this case, Cancel and return to Align (manual alignment) then repeat Quick 
Points. If the points still miss the stereo area, don’t worry. The points are not locked to the 
magenta “+” mark locations; you may move them during measurement. Putting them in the 
stereo area is mostly for the convenience of not having to move them very far. 

For the following steps, make sure that the Auto Next button is not checked (not blue)Having Auto Next 
off allows you to pick multiple times on the same feature to refine the measurement. 

4. Click on the point in the list that you would like to measure. There are two options for 
measurement: The simple system mouse pick method (A. below, recommended) and the 
lock image method (B. below). 
 
A. Simple system mouse pick method (recommended): This is the newer and more 

convenient method. Tie Points will open with Side by Side checked on by default. This 
places the left and right images in separate views for separate measurements. 
 
Click the left system mouse button on the same distinct feature in the left and right 
images.  
 
Note: It’s best to select an object on the ground that has a distinct shape and does not 
move. Do not select points on the top of thin, high objects, such as sign posts. Do not 
select moving objects, such as cars and boats, even if they seem stationary. In general, 
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do not pick points on the tops of trees, in case the wind was moving the branches; the 
exception is if the entire model or Von Gruber area is covered with thick trees and no 
ground is visible, and even then, be careful to measure unique branches that you are 
sure are the same feature. 
 
Use the Zoom 1:n buttons on the toolbar or spin the system mouse wheel to zoom out if 
you need to see a bigger area to find a feature to match. This is a rough match if 
zoomed out. Following this measurement in the left and right images, the Measured 
column will show Yes for the point, but remember, it may be only a rough match at this 
time. 
 
After clicking a rough match at a zoomed-out view, use the Zoom 1:n buttons on the 
toolbar or spin the system mouse wheel to zoom in. When zoomed in, click again on the 
feature to refine the measurement on the images, if necessary. Pick again any number 
of times until the match is acceptable. 

 

 
 

Click on the next point in the list. Repeat zooming out, picking the left and right position, 
zooming in, and refining the measurement until all points are matched and measured. 
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B. Lock Image Method: This is the older and more difficult method, so it may be 
considered obsolete, although it is still available. This method may be measured in 
either Side By Side on or off (off is in stereo). 
 
To begin measuring using the Lock Image Method, click the right system mouse button 
in the Stereo Viewer main view. This changes the system mouse to a full Stereo Viewer 
measurement/digitizer mode; it no longer behaves as a system mouse when in this 
mode. When you move the mouse, the images will shift under the cursor. 
 
While in measurement mode, zoom in on the object you will be measuring. If you are in 
measure mode, you can do this by holding down the control button and spinning the 
mouse wheel. If you are not yet in measure mode, then spin the mouse wheel to zoom. 
 
Make sure that the Lock Image button is not highlighted (it is gray). Move the red cursor 
in the right image to the object you have decided to measure. The cursor on the left 
image will probably not be perfectly aligned with the object at this time. That is 
expected. 

 

Example of Lock Image off (light gray color indicates off) 

With the right image point selected, right-click the mouse or press Escape on the 
keyboard to exit Measure Mode. 
 
Press the Lock Image button. This will lock in the measurement for the right image. 
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Now right-click the mouse to re-enter movement mode and move to the same object in 
the left image. If Side By Side is off, align the cursor on the object in stereo. When the 
cursor is on it, measure it by clicking the left mouse button. 

 

 

Example of Lock Image on (blue highlight indicates on) 

Following the left mouse button click, the Measured column will show a Yes for that 
point. 

 

Example of one point measured, showing Yes in the Measured column 
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Note: It’s best to select an object on the ground that has a distinct shape and does not 
move. Do not select points on the top of thin, high objects, such as sign posts. Do not 
select moving objects, such as cars and boats, even if they seem stationary. In general, 
do not pick points on the tops of trees, in case the wind was moving the branches; the 
exception is if the entire model or Von Gruber area is covered with thick trees and no 
ground is visible, and even then, be careful to measure the most unique branches that 
you are sure are the same feature. 

 
Now that you have measured your first tie point in measurement/digitizer mode, zoom 
out, select the next unmeasured tie point in the dialog, and choose another object that 
appears in both images.  Repeat to measure six, eight, or more tie points across the 
entire overlap region. 

 
5. Once you have measured at least six or eight points, you will see residual values indicating 

the quality of the resulting orientation. 
 

• If you see a large number in the Residuals column (greater than 1.0, depending on 
the quality of your images), it is particularly important to review the measurements 
to see if you can refine the measurements.  
 

• If residuals are very large, search for gross errors. Click on each measured point in 
the dialog and make sure the same object was measured in both images. If not, 
remeasure the point. 

 
• To generally improve any initial residuals, click on the Residuals column title once or 

twice to sort the highest residuals at the top. Click on the point with the highest 
residual, zoom in, and remeasure to try to improve the residuals. Repeat until the 
residuals are acceptable overall. 
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• You may also test your stereo solution using the Test button. This will allow the 
cursor to move around in the pseudo relative stereo view as defined by the 
currently measured points’ solution. View the stereo results to see if they are 
acceptable. When finished, unselect Test to return to Relative Orientation 
measurement mode. 

 
• If you hover the mouse cursor over the Measured column, it will display the pixel 

coordinates for each image. 

 

A tooltip shows the pixel coordinates of the measurement 

 
6. When you are satisfied with the solution, press the Apply button to activate the results and 

then close the dialog.  

Measure Tie Points Automatically  
The manual method can be time consuming. Fortunately, there is a faster way. Tie points may be 
generated automatically using the Generate button. The setup is identical to the manual method, but 
rather than manually selecting and measuring each point, Stereo Viewer will generate tie points for you. 
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Sometimes this method fails and in general it will always provide some points that are not good. This 
section covers generating points as well as locating and removing bad points.  

 
Example of the results of automatic RO tie point generation 

 

To run the Automatic Tie Point method: 



  
 

Page 15 of 20 
 

1. Select Stereo Viewer > Orientation > Tie Points > Generate button. This Generate Tie Points 
dialog will appear. Press the Process button. The Generate Tie Points tool will generate several 
candidate points. 

 

Generate and Process buttons for automatic tie point generation 
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2. In order to identify inaccurate points in the solution, sort the points by their residuals. This can 
be done by clicking once or twice on the Residuals (mm) column to sort the highest residuals to 
the top of the list. 
 

 
Example of Residuals sorted with the highest at the top of the list 

  
3. Pick the point with the highest residual value. Stereo Viewer will drive the cursor to that point. 

In some cases, the point will be obviously incorrect. In others it may be more difficult to tell 
whether it is wrong. Look for objects that are similar, but not the same, such as a row of similar 
painted marks on a parking lot or a row of guard rail posts. Also look for moving objects such as 
cars, trucks, or boats; they make poor tie points. 
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4. To delete poor tie points, select them and press the Delete button. Examples: 

 
• Below is an example of a car on a freeway. It is the same car, but since the car is moving, 

it may not be used as a tie point. Press the Delete button to remove bad tie points. 

 

Example of the same object that has moved between images (delete) 
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• Below is an example of objects that are similar, but not the same. In this case you 
may either re-measure the object manually or just delete the measurement. It is not 
recommended to use cars as tie points, even if they appear to be parked. 

 

Example of different objects that are similar enough to create a false match (remeasure or delete) 

 
5. While you are deleting and remeasuring objects, keep an eye on the Overview window in the 

upper left. Make sure that you have a fairly even distribution of measured points across the 
entire overlap area.  
 
For best results, ensure there are points in at least the six Von Gruber locations (Von Gruber 
points are traditional for photogrammetry: Upper left, center left, lower left, upper right, center 
right, and lower right, all somewhat inside the edge of the stereo area). It is acceptable to have 
many more points than in the Von Gruber locations, but if it misses the general area of one or 
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more Von Gruber locations, you should manually measure a point in each missing area, if 
possible. It may not be possible if the area shows a lake or the ocean. 
 
Manually add points to areas that do not currently have points. 
 

 
Find any areas that lack points and manually measure more 

 
6. Make sure that you have at least six points that cover most of the overlap area to obtain a high-

quality stereo view. If you intend to try Rectify later, you should have at least eight points. Press 
Apply and then close the dialog when you are finished. 

 

Rectified Orientation 
Rectify is the preferred method to get the best stereo, but only if it gives good results. It is optional. 

Try Rectify only after the project has at least eight manually or automatically measured tie points (see 
sections above). 

Rectify uses computer vision methods to generate new rectified imagery. To use: 

1. Select Stereo Viewer > Orientation > Rectify. This dialog will generate two rectified images and 
a project file containing those images. 

 
Rectify asks for the .smtxml that contains eight or more tie points 
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2. To check out the orientation, load the new project (Stereo Viewer > File > Open the resulting 
.smtxml). 

 

Potential Failure of Rectified Orientation: The Rectified Orientation is the preferred method, but it does 
not always work. On typical image pairs, DAT/EM testing did very well; however, the following images 
with a 55 degree rotation had problems during beta testing: 

 
These were the images supplied courtesy of Schneider Digital, makers of PluraView monitors. The 
DAT/EM Stereo Viewer rectification had inconsistent results on such images. In cases like this, the 
pseudo relative (RO Tie Points alone) will have to suffice. 
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